sincerity.network/overlay/default.nix
Anish Lakhwara 2c1dc0899c make bonfire actually build
waiting on upstream to merge my pr before we can deploy it
2022-09-28 22:01:17 +10:00

17 lines
579 B
Nix

# This file defines two overlays and composes them
{ inputs, ... }:
let
# This one brings our custom packages from the 'pkgs' directory
additions = final: _prev: import ../pkgs { pkgs = final; inputs = inputs; };
# This one contains whatever you want to overlay
# You can change versions, add patches, set compilation flags, anything really.
# https://nixos.wiki/wiki/Overlays
modifications = final: prev: {
# example = prev.example.overrideAttrs (oldAttrs: rec {
# ...
# });
};
in
inputs.nixpkgs.lib.composeManyExtensions [ additions modifications ]