54 lines
1.5 KiB
Nix
54 lines
1.5 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "thunderbolt" "uas" "usb_storage" "sd_mod" ];
|
||
boot.initrd.kernelModules = [ "dm-snapshot" ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{
|
||
device = "/dev/disk/by-uuid/ade0752d-84d3-4e39-865b-9027ba2d5c67";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/boot/efi" =
|
||
{
|
||
device = "/dev/disk/by-uuid/1715-278E";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
fileSystems."/mnt/one" =
|
||
{
|
||
device = "/dev/disk/by-uuid/0f857c6e-509d-436f-9e78-bc25f1b0d23b";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/mnt/two" =
|
||
{
|
||
device = "/dev/disk/by-uuid/5bc894bf-ed87-4c30-aab4-87e154e0cd08";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/mnt/three" =
|
||
{
|
||
device = "/dev/disk/by-uuid/0be3ded1-9c8b-40aa-94ca-dc2297d5988e";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices =
|
||
[{ device = "/dev/disk/by-uuid/b790abb4-ba5f-4476-8f09-b0fc575414aa"; }];
|
||
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
nixpkgs.hostPlatform = "x86_64-linux";
|
||
}
|