35 lines
1 KiB
Nix
35 lines
1 KiB
Nix
{ config, pkgs, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
# Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
];
|
||
|
||
boot.loader.grub.enable = true;
|
||
boot.loader.grub.version = 2;
|
||
boot.loader.grub.device = "/dev/vda"; # or "nodev" for efi only
|
||
|
||
networking.hostName = "cube"; # Define your hostname.
|
||
time.timeZone = "Australia/Brisbane";
|
||
|
||
networking.useDHCP = false;
|
||
networking.interfaces.ens3.useDHCP = true;
|
||
i18n.defaultLocale = "en_US.UTF-8";
|
||
|
||
environment.systemPackages = with pkgs; [
|
||
vim
|
||
gitAndTools.gitFull
|
||
];
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "21.11"; # Did you read the comment?
|
||
}
|
||
|