27 lines
481 B
Nix
27 lines
481 B
Nix
{ self, profiles, suites, ... }:
|
|
{
|
|
imports = [
|
|
./configuration.nix
|
|
../profiles/core
|
|
../profiles/server
|
|
../profiles/metrics
|
|
../profiles/gitea
|
|
../profiles/rss-bridge
|
|
../profiles/mount-mossnet
|
|
../profiles/freshrss
|
|
];
|
|
|
|
# Capsul specific
|
|
users.users.cyberian = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
};
|
|
|
|
mossnet.wg = {
|
|
enable = true;
|
|
ips = [ "10.0.69.5/24" ];
|
|
privateKeyFile = "/home/anish/wg/wg-priv";
|
|
};
|
|
|
|
}
|