28 lines
799 B
Nix
28 lines
799 B
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
(modulesPath + "/profiles/qemu-guest.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "ata_piix" "floppy" "virtio_pci" "sr_mod" "virtio_blk" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{
|
||
device = "/dev/disk/by-uuid/7c560634-d545-41cc-b375-42ce3037fd73";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
nixpkgs.hostPlatform = "x86_64-linux";
|
||
}
|